Issues with login. Possible problem interactions between iOS 'passwords' framework on iPhone

darsynia

Moderator
Staff member
This one is tricky to explain! It is almost certainly an iOS issue (in that Android probably doesn't have this problem). I 100% tried to take screenshots for you but here's the funny part: all the issues involve unlocking with my fingerprint. In order to take pictures, I have to use the fingerprint sensor button, which either works too fast for the screenshot to work, OR errors, because I hit it in a way that doesn't allow the sensor to detect a fingerprint! First. World. Problems. Here's what happened without commentary:

I clicked on the email notification of a new reply to a watched conversation.
In order to view it, I needed to log in.
I have an option to use the cached information of my login, which activates with my fingerprint.
When it registers my fingerprint, it displays the correct login information (Darsynia | ****) for about a second, then it wipes away/disappears.
edit: this disappearing happens before I can hit 'log in;' however, I think that using the passwords framework ends up hitting enter as part of using it. Not 100% sure though.
After seeing it do this twice, I tried to do it manually.
I typed in 'Darsynia' and then was given a different option to use the 'Passwords' cache to place in my password, with my fingerprint.
Doing this also displayed properly, then disappeared.
Lastly, I typed everything in by hand.
After hitting enter, everything disappeared.

EDIT: by 'disappeared' I mean that it wiped the information away and presented me with the login screen as if I'd done nothing.

Now, I troubleshooted to see if when I typed it in by hand, I had used the wrong password, but it was the correct password. It works on the desktop site just fine. When my husband comes home, I'm going to try to log into the site for the first time, by hand, on his phone, which is running the same iOS and is the same model, an iPhone 8 plus. If it doesn't allow me to log in at all (which would not involve the 'password' framework cache at all), that's a second, separate problem!

I have this picture in my mind of someone bringing a really awful present to someone else and saying 'I'll just leave this here,' lol.

I'll just... leave this here.
 
Last edited:

darsynia

Moderator
Staff member
I've successfully logged into the forums on my husband's identical phone. So there's definitely a problem with the coding when there are saved passwords, that is negatively interacting with the log in page.

If you'd like me to try sometime tomorrow after he's home from work, I can save the password in his password cache and then try to use it and see whether there's something wonky just with my particular phone or the code at large (it's probably the latter, as I can't imagine why my phone in particular would be messed up like that).
 
Top